skip to Main Content

On client side, i use dd/MM/yyyy date format. The field use a twitter bootstrap 3 datetime picker (

I enter via twitter bootstrap 3 datetime picker 24/07/2015
in my json i sent, i see: birthdate: “24/07/2015”

In my dto, i do

@JsonFormat(shape = JsonFormat.Shape.STRING, pattern = "dd/MM/yyyy")
private Date birthdate;

When i receive the date on the server, in my dto see: 23/07/2015 19:00

One day is lost.

Any explication?



  1. According to JacksonFAQDateHandling page:

    All time objects that have associated TimeZone (java.util.Calendar
    etc) that Jackson constructs use the standard timezone (GMT), not the
    local time zone (whatever that might be). That is: Jackson defaults to
    using GMT for all processing unless specifically told otherwise.

    In your case, it looks like the date is automatically being converted to GMT/UTC. Try to provide your local timezone explicitly to avoid UTC conversion [as mentioned in the question How come this time is off by 9 hours? (5 hours, 3 hours etc) on same page]:

    @JsonFormat(shape=JsonFormat.Shape.STRING, pattern="dd/MM/yyyy", timezone="EST")

    Secondly, I think you are using Date.toString() to print date. Note that java Date class is timezone independent but its toString() method uses the system’s default timezone before printing.

    Here it looks like 24/07/2015 00:00 UTC is being converted to 23/07/2015 19:00 EST by toString(). Both of these represent the same moment of time but in different timezones.

    Login or Signup to reply.
  2. AimZ answer is what pointed me to this but I added these three lines to my file and achieved the same thing



    Login or Signup to reply.
  3. Had the same issue. Using postman to verify that the client is not the culprit. Seems like an issue with the timezone Jackson is using vs the timezone of the system. Had to change the Jackson config to compensate for dates

    public class JacksonConfig {
        public Jackson2ObjectMapperBuilder jackson2ObjectMapperBuilder() {
            final Jackson2ObjectMapperBuilder jackson2ObjectMapperBuilder = new Jackson2ObjectMapperBuilder();
            return jackson2ObjectMapperBuilder;
    Login or Signup to reply.
  4. I had the same issue in JavaScript when selecting dates from a datepicker. I formatted the fields using .toString() method but the function gave me a different date (I was messing a day as well). Like this:

    var mydate = new Date('2020-04-03');

    //Thu Apr 02 2020 20:00:00 GMT-0400 (Eastern Daylight Time)

    I fixed it ussing .toUTCString() instead.

    var mydate = new Date('2020-04-03');
    //Fri, 03 Apr 2020 00:00:00 GMT
    Login or Signup to reply.
  5. I had the same issue in java. You can use ObjectMapper to set to default timezone

    ObjectMapper mapper = ((MappingJackson2HttpMessageConverter) converter).getObjectMapper();

    Solution here: Jackson @JsonFormat set date with one day less

    Full configuration class:

    public class WebMvcConfiguration implements WebMvcConfigurer {
    public void extendMessageConverters(List<HttpMessageConverter<?>> converters) {
        for (HttpMessageConverter converter : converters) {
            if (converter instanceof org.springframework.http.converter.json.MappingJackson2HttpMessageConverter) {
                ObjectMapper mapper = ((MappingJackson2HttpMessageConverter) converter).getObjectMapper();
                mapper.registerModule(new Hibernate5Module());
    Login or Signup to reply.
  6. I faced this same problem this week. For us the problem was the Decoder that we were using.
    Our project is using feing and to decode our JSON we were using JacksonDecoder, so we changed to GsonDecoder, so problem solved.

    private fun servico(): IUsuarioServiceDeskClient {
        return Feign.builder()
            .options(Request.Options(240000, 240000))
            .target(, urlBase)
    Login or Signup to reply.
Please signup or login to give your own answer.
Back To Top