skip to Main Content

Not sure if it’s related to Zscaler, but I started to receive this warning about the Docker.app the same day that I installed and restarted Zscaler.

Full warning:
"Docker.app" will damage your computer. You should move it to the Bin

I am using MacOS Intel.

docker.app will damage your computer

2

Answers


  1. Chosen as BEST ANSWER

    I solved extracting the Docker.app from the Docker.dmg after mounting it and copying it into /Applications/ using

    mv ~/Downloads/Docker.app /Applications/
    

    Another potential solution can be running the following command and dragging the Docker.app in /Applications/ again:

    softwareupdate --install-rosetta
    

    source


  2. There is an official response from Docker regarding attempts to resolve this issue, as well as suggested workarounds. The following is copied from the GitHub PR: https://github.com/docker/for-mac/issues/7520.

    Note: While I cannot confirm if the creator of the PR represents Docker, the official Docker account references this PR on LinkedIn.

    If you face this issue, try the following procedure:

    1. Quit Docker Desktop and ensure no remaining Docker processes are running using the Activity Monitor.

    2. Run the following commands:

      #!/bin/bash
      
      # Stop the docker services
      echo "Stopping Docker..."
      sudo pkill '[dD]ocker'
      
      # Stop the vmnetd service
      echo "Stopping com.docker.vmnetd service..."
      sudo launchctl bootout system /Library/LaunchDaemons/com.docker.vmnetd.plist
      
      # Stop the socket service
      echo "Stopping com.docker.socket service..."
      sudo launchctl bootout system /Library/LaunchDaemons/com.docker.socket.plist
      
      # Remove vmnetd binary
      echo "Removing com.docker.vmnetd binary..."
      sudo rm -f /Library/PrivilegedHelperTools/com.docker.vmnetd
      
      # Remove socket binary
      echo "Removing com.docker.socket binary..."
      sudo rm -f /Library/PrivilegedHelperTools/com.docker.socket
      
      # Install new binaries
      echo "Installing new binaries..."
      sudo cp /Applications/Docker.app/Contents/Library/LaunchServices/com.docker.vmnetd /Library/PrivilegedHelperTools/
      sudo cp /Applications/Docker.app/Contents/MacOS/com.docker.socket /Library/PrivilegedHelperTools/
      
    3. Restart Docker Desktop.

    If that still doesn’t work, download one of the currently supported releases from the Release Notes and reapply step 2.

    Login or Signup to reply.
Please signup or login to give your own answer.
Back To Top
Search