skip to Main Content

I am running code::blocks on antix Linux (Debian 12 bookworm). When I run a simple Hello World program,

#include <stdio.h>

int main() {
    printf("Hello, world!n");
    return 0;

already tested and working manually in console, I got the following output:

-------------- Build: Debug in test (compiler: GNU GCC Compiler)---------------

g++ -L/usr/local/lib/x86_64-linux-gnu -L"-static-libgcc -static-libstdc++" -o bin/Debug/test obj/Debug/main.o   
Output file is bin/Debug/test with size 30.12 KB
Process terminated with status 0 (0 minute(s), 0 second(s))
0 error(s), 0 warning(s) (0 minute(s), 0 second(s))

-------------- Run: Debug in test (compiler: GNU GCC Compiler)---------------

Checking for existence: /home/Jackie/Documents/test/bin/Debug/test
Set variable: LD_LIBRARY_PATH=.:/usr/local/lib/x86_64-linux-gnu:
Executing: xterm -T test -e /usr/bin/cb_console_runner LD_LIBRARY_PATH=:.:/usr/local/lib/x86_64-linux-gnu /home/Jackie/Documents/test/bin/Debug/test  (in /home/Jackie/Documents/test/.)
Process terminated with status -1 (0 minute(s), 0 second(s))

I have tried two workarounds suggested a long time ago on the codeblocks forum:,,9197.msg74121.html#msg74121 (second to last post)

I have the feeling that this is actually not too hard to figure out, but I am out of ideas…



  1. Chosen as BEST ANSWER

    I have found the problem. AntiX Linux is using the ROXterm terminal. Or maybe the name was changed from xterm to ROXterm? Anyway, adding rox at the beginning of the line in codeblocks Settings -> Evironment -> Terminal to launch console programs did the trick.

    xterm -T $TITLE -e     ---->      roxterm -T $TITLE -e

  2. I am using arch based linux Manjaro. I also hade the same problem. I just install a software from pacman.
    the name of the software is:

    XTerm (stream)

    its a standard terminal emulator for the X window system. my problem got solved.

    Login or Signup to reply.
Please signup or login to give your own answer.
Back To Top