skip to Main Content

I apologize if this issue has been resolved somewhere, but every other question I looked at with a similar name was unable to resolve my problem. I have a plunker with a barebones layout of a web app I am working on, but for some reason am receiving an Uncaught Error: [$injector:modulerr] when I try to run it.

I have attached the Plunk below, hopefully someone can point out what the issue is, because I cannot find it. I am using ui-router and ui-bootstrap with twitter-bootstrap styling.


(Never shared a plunk before, so hopefully I did it correctly.)



  1. You didnt include your app file in the script srcs

    forked plnkr

    <script src="app.js"></script>
    Login or Signup to reply.
  2. You are never including your app.js file, so your Angular module is never actually defined.

    I tried adding this line to your plunk and it worked fine.

     <script src="app.js"></script>
    Login or Signup to reply.
Please signup or login to give your own answer.
Back To Top