skip to Main Content

I transfered my website to a new dedicated server which is CENTOS and PHP Version 5.3.3 with PLESK.

My problem is this, I’m getting “No input file specied” error in everypage expect homepage. Firstly i think it’s a chmod problem than i set it to 755 to all folders and files in httpdocs

Secondly googled and find a solution about .htaccess

My .htaccess is:

SetOutputFilter DEFLATE
AddDefaultCharset UTF-8
DefaultLanguage tr-TR
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L]

And i changed

RewriteRule ^(.*)$ index.php?/$1 [L]

By this changes site started to work in a different way. There wasn’t any error but in everypage i am redirecting to homepage.

Hovewer when i write index.php into the url as

I can reach the page that i want

Than, I changed php.ini, cgi.fix_pathinfo=0 nothing changed than Finally i decided to write here, thanks for your help.

Site :  
A page :  
I can reach :  



  1. Chosen as BEST ANSWER

    I see that it's about fastcgi problem, i changed it to apache module from plesk control panel - PHP support (Run PHP as apache module)

    Now it's working

  2. Bumped into the same issue and it wasnt an option for me to use mod_php instead of fast-cgi.

    Simply had to fix permissions using :

    find ./ -type d -exec chmod 0755 '{}' ;
    find ./ -type f -exec chmod 0644 '{}' ;

    Everything went smooth after that.

    Login or Signup to reply.
Please signup or login to give your own answer.
Back To Top