skip to Main Content

I,m trying to install a joomla site in parallels plesk panel via akeeba backup . Where I,m facing file permission issue.

An error occured

Could not open /var/www/vhosts/ for writing.

As searched all over and also in Plesk forum . I found this is a very common problem. Some suggested installing mod_suphp can solve the problem. I tried but don’t know is it successfully installed or not.

Then I have created a new service plan from where in hosting parameter I select Run PHP as FastCGI

After that I took my domain to that service plan. I thought it will solve the problem. But still getting same error. Can anyone help please ?



  1. On the ssh command line try:

    find /var/www/vhosts/ -type f -exec chmod 664 {} ;
    find /var/www/vhosts/ -type d -exec chmod 775 {} ;

    these will set the permissions correct for writing to by user and group for files (f) and directories (d). you also need to make sure that apache is in the psacln and psaserv groups in the /etc/group file: the lines should look like this:


    Then you can run the commad:

    chown -R siteusername.psacln /var/www/vhosts/*

    where “siteusername” is the username of the site’s files.

    Hope this helps.

    Login or Signup to reply.
  2. this is common issue in linux and users had shared hosting.

    So simple.
    If you already selected PHP module with FAST CGi so follow the following steps:
    Open file manager
    Make new folder “ABC”
    Click “ALL” on right side to view all files on the tree.
    Select all files and folders except “plesk-stats”
    Select Copy/move button
    in the path filed type /httpdocs/abc/
    Click Move.

    If all files moved and then open “abc” folder
    Select all files and folders.
    Select Copy/move button
    in the path filed type /httpdocs/

    that’s it issue sorted out.

    I tried these steps for many clients.

    I hope this helps for someone.

    Login or Signup to reply.
Please signup or login to give your own answer.
Back To Top