skip to Main Content

I have a server with Plesk installed.
On that I’ve created a domain,, and added and e-mail account [email protected] with access to SMTP for sending e-mails.

With PHPMailer or Swift Mailer I am able to send via the SMTP account [email protected] whenever the from address is outside the, for example [email protected].
Whenever I’m using an e-mail address that ends on it fails.

I’ve tried to look in the /usr/local/psa/var/log/maillog file, but it only stores the mails that doesn’t fail.

Can someone help me figure out where the problems is?



  1. You can try this:

    Delete the related domain in the qmail file /var/qmail/control/virtualdomains
    Then reload/restart qmail. Now it should work.
    More technical background at

    Login or Signup to reply.
  2. Benjamin answer didn’t work on my installation (Plesk 11.5), but I found another solution:
    just turn off the mail service itself. It might not be the solution for everyone but it was for me (my domain’s mx records pointing to another server, with some scripts sending emails here and there).

    You can turn off the mail service fairly easily using Plesk GUI.

    Mail tab then Change Settings button

    Then uncheck

    Uncheck 'Activate mail on service on domain'

    However, this won’t turn it off for subdomains and secondary domains you might have. No problem, just log in with ssh and run this command:

    /usr/local/psa/bin/domain -u -mail_service false

    And if one day you decide you want to turn it back on just replace false by true.

    Login or Signup to reply.
Please signup or login to give your own answer.
Back To Top