skip to Main Content

This has taken me hours already.
I’ve a new server with a fresh PLESK 10 installation. Now subdomains are handled differently in PLESK 10, that I know (not domain.tld/subdomains/httpdocs but domain.tld/httpdocs_subdomain for instance).

Now, I got a subdomain working over HTTP perfectly. However, when I change it to https://subdomain.domain.tld it just gives me a Default page.

In older versions, one could select “use one directory for both http and https” but PLESK 10 seems to make no difference anymore. However… Why do I get a Default Page when using https? And more important: How to fix this?

I hope someone can help me out!



  1. Plesk 10 changes the way it manages http and https.
    Both http and https point to the same directory now.

    When you create a subdomain in Plesk 10, a directory is created in your http root and in the subdomains folder, so say you create a subdomain called “secure”, you’ll get:

    • /secure
    • /subdomains/secure

    As for your issue, is SSL enabled for that subdomain?

    Within Plesk 10 ensure you have SSL enabled:

    • Website & Domains
    • Click on your subdomain
    • Check Enable SSL Support
    Login or Signup to reply.
  2. Maybe its easy:

    • Open Plesk
    • Click on required Domain
    • Click on File Manager
    • Click Sub Domain Folder.
    • Click Add File
    • Give the path and Click on some buttons.

    It does not matter if you are using plesk with https ot http, because even configured over SSL it always fetch the files from httpdocs folder.

    Login or Signup to reply.
Please signup or login to give your own answer.
Back To Top